Flash 7 player required.

They Rule uses Macromedia Flash software. Unfortunately, you have an old version of Macromedia Flash Player that cannot run the latest version of They Rule.



Why not download and install the latest version now? It will only take a moment.

You can still view the 2001 version of They Rule in Flash 5.